NutzCN Logo
问答 关于nutz链接sqlserver14不支持问题
发布于 84天前 作者 qq_a96bd60c 209 次浏览 复制 上一个帖子 下一个帖子
标签:

如题,使用nutz配置数据源为sqlserver,并且版本为2014.报错如下:
by setter org.nutz.dao.impl.DaoSupport.'setDataSource()' because [java.lang.RuntimeException: Can not support database 'Microsoft SQL Server 14.00.1000']: Can not support database 'Microsoft SQL Server 14.00.1000'
at org.nutz.lang.Lang.makeThrow(Lang.java:94)
at org.nutz.lang.inject.InjectBySetter.inject(InjectBySetter.java:31)
at org.nutz.ioc.weaver.FieldInjector.inject(FieldInjector.java:24)
at org.nutz.ioc.weaver.DefaultWeaver.fill(DefaultWeaver.java:56)
at org.nutz.ioc.impl.ObjectMakerImpl.make(ObjectMakerImpl.java:96)
... 21 more

sqlserver驱动没有问题,手动可以连接。

4 回复

额, 用的是什么版本呢?

"microsoft sql server.*(11|12|13|14|15)[.].+" : "org.nutz.dao.impl.jdbc.sqlserver2005.Sqlserver2005JdbcExpert",

sqlserver2014 jdbc:7.2.1.jre8 nutz:1.48.3b
新版本也试过

67/68肯定行

添加回复
请先登陆
回到顶部