NutzCN Logo
问答 是否考虑把activiti的版本升级到6.0
发布于 11天前 作者 BaTianCheng 75 次浏览 复制 上一个帖子 下一个帖子
标签: fireflow

去年的时候,activiti的版本已经是6.0以上了,相比较之前的版本,多了DMN决策引擎,表单引擎和消息队列的作业执行器,还对原有的代码进行了重构,将代码结构调整的更加合理。所以我觉得是否可以把nutz中activiti的版本升级一下,这样可以更好的使用新特性

4 回复

指插件?应该兼容的吧?

来自炫酷的 NutzCN

@wendal 我的意思是在pom文件中,就把引用升级到6.0,由于Activiti代码结构变化,需要做一些修改。具体的修改,我在git上pull request,也经过原来test下的测试了,希望可以采纳

		<dependency>
			<groupId>org.activiti</groupId>
			<artifactId>activiti-engine</artifactId>
			<version>6.0.0</version>
			<exclusions>
				<exclusion>
					<groupId>org.springframework</groupId>
					<artifactId>spring-beans</artifactId>
				</exclusion>
			</exclusions>
		</dependency>

哦哦,需要测试相关的项目,麻烦等待一下^_^

来自炫酷的 NutzCN

添加回复
请先登陆
回到顶部