NutzCN Logo
问答 application.properties设置web.session.timeout=720,重启后没有生效
发布于 32天前 作者 qq_e8721d33 117 次浏览 复制 上一个帖子 下一个帖子
标签:

我在application.properties设置:
web.session.timeout=720
swagger.enable=false
但都没有生效,请问我是属性搞错了,还是不应该在application.properties文件配置呢?

4 回复

大概是个怎么的使用环境,不会是打包成war了吧

只是在idea调试
application.properties

server.port=8080
server.host=127.0.0.1
jdbc.type=druid
jdbc.url=jdbc:h2:mem:~
jdbc.username=root
jdbc.password=root
redis.host=127.0.0.1
redis.port=6379
redis.timeout=2000
redis.database=0
swagger.enable=false
web.session.timeout=720

启动显示:

|117 |swagger.enable                          |no        |                    |true      |是否启用swagger         |org.nutz.boot.starter.swagger.SwaggerServletStarter|
|120 |web.session.timeout                     |no        |                    |30        |Session空闲时间,单位分钟    |org.nutz.boot.starter.jetty.JettyStarter|

我打印日志:

log.info("jdbc.url="+conf.get("jdbc.url"));
log.info("web.session.timeout="+conf.get("web.session.timeout"));
log.info("swagger.enable="+conf.get("swagger.enable"));

才发现,值是改了的:

2021-08-22 20:00:27,564  INFO MainLauncher:26 web.session.timeout=720
2021-08-22 20:00:27,564  INFO MainLauncher:27 swagger.enable=false

但为什么这个Configure Manual却显示错误的值呢?

2021-08-22 20:00:25,681  INFO NbApp:310 Configure Manual:
|117 |swagger.enable                          |no        |                    |true      |是否启用swagger         |org.nutz.boot.starter.swagger.SwaggerServletStarter|
|120 |web.session.timeout                     |no        |                    |30        |Session空闲时间,单位分钟    |org.nutz.boot.starter.jetty.JettyStarter|

自问自答吧,configure manual打印的是默认值,取消启动打印默认值的方式为setPrintProcDoc(false)
```java
new NbApp().setArgs(args).setPrintProcDoc(false).run();

```

添加回复
请先登陆
回到顶部