NutzCN Logo
问答 nboot启动错误??
发布于 196天前 作者 Rekoe 283 次浏览 复制 上一个帖子 下一个帖子
标签:

控制台这种错误是因为包冲突还是没有这个包
````
[ERROR] 2019-05-28 09:05:32.137 org.nutz.boot.NbApp.execute(NbApp.java:224) - something happen!!
java.lang.NoSuchMethodError: javax.servlet.ServletContext.getClassLoader()Ljava/lang/ClassLoader;
at io.undertow.websockets.jsr.Bootstrap.handleDeployment(Bootstrap.java:92)
at io.undertow.servlet.core.DeploymentManagerImpl.handleExtensions(DeploymentManagerImpl.java:262)
at io.undertow.servlet.core.DeploymentManagerImpl.deploy(DeploymentManagerImpl.java:152)
at org.nutz.boot.starter.undertow.UndertowStarter.init(UndertowStarter.java:136)
at org.nutz.boot.AppContext.init(AppContext.java:284)
at org.nutz.boot.NbApp.execute(NbApp.java:206)
at org.nutz.boot.NbApp.run(NbApp.java:182)
at cc.mumshop.cloud.crawler.CloudCrawlerLauncher.main(CloudCrawlerLauncher.java:301)

```

5 回复

有低版本的serlvet api

兽 我查了下 只查到nboot 3.5.6依赖了servler-api_3.1版本的 没有查到其他的,有什么方法定位么
还有 升级到nboot3.5.6提示这个错误 貌似是版本问题

[ERROR] 2019-05-28 09:15:24.452 org.nutz.boot.NbApp.execute(NbApp.java:224) - something happen!!
java.lang.NoSuchMethodError: org.nutz.boot.starter.WebServletFace.isAsyncSupported()Z
	at org.nutz.boot.starter.servlet3.NbServletContextListener.lambda$contextInitialized$0(NbServletContextListener.java:103)
	at java.util.ArrayList.forEach(ArrayList.java:1249)
	at org.nutz.boot.starter.servlet3.NbServletContextListener.contextInitialized(NbServletContextListener.java:87)
	at io.undertow.servlet.core.ApplicationListeners.contextInitialized(ApplicationListeners.java:187)
	at io.undertow.servlet.core.DeploymentManagerImpl$1.call(DeploymentManagerImpl.java:204)
	at io.undertow.servlet.core.DeploymentManagerImpl$1.call(DeploymentManagerImpl.java:173)
	at io.undertow.servlet.core.ServletRequestContextThreadSetupAction$1.call(ServletRequestContextThreadSetupAction.java:42)
	at io.undertow.servlet.core.ContextClassLoaderSetupAction$1.call(ContextClassLoaderSetupAction.java:43)
	at io.undertow.servlet.core.DeploymentManagerImpl.deploy(DeploymentManagerImpl.java:238)
	at org.nutz.boot.starter.undertow.UndertowStarter.init(UndertowStarter.java:136)
	at org.nutz.boot.AppContext.init(AppContext.java:284)
	at org.nutz.boot.NbApp.execute(NbApp.java:206)
	at org.nutz.boot.NbApp.run(NbApp.java:182)
	at cc.mumshop.cloud.crawler.CloudCrawlerLauncher.main(CloudCrawlerLauncher.java:301)

包依赖

[INFO]
[INFO] --- maven-dependency-plugin:2.8:tree (default-cli) @ crawler-rest ---
[INFO] cc.mumshop.cloud.crawler:crawler-rest:jar:1.0-SNAPSHOT
[INFO] +- com.baidu.aip:java-sdk:jar:4.11.0:compile
[INFO] |  \- org.json:json:jar:20160810:compile
[INFO] +- cc.mumshop.cloud.crawler:crawler-common:jar:1.0-SNAPSHOT:compile
[INFO] |  +- cc.mumshop.cloud.crawler:crawler-core:jar:1.0-SNAPSHOT:compile
[INFO] |  |  +- com.github.liaochong:myexcel:jar:2.2.1:compile
[INFO] |  |  +- com.aliyun.oss:aliyun-sdk-oss:jar:3.1.0:compile
[INFO] |  |  |  +- org.jdom:jdom:jar:1.1:compile
[INFO] |  |  |  +- com.sun.jersey:jersey-json:jar:1.9:compile
[INFO] |  |  |  |  +- org.codehaus.jettison:jettison:jar:1.1:compile
[INFO] |  |  |  |  +- org.codehaus.jackson:jackson-core-asl:jar:1.8.3:compile
[INFO] |  |  |  |  +- org.codehaus.jackson:jackson-mapper-asl:jar:1.8.3:compile
[INFO] |  |  |  |  +- org.codehaus.jackson:jackson-jaxrs:jar:1.8.3:compile
[INFO] |  |  |  |  +- org.codehaus.jackson:jackson-xc:jar:1.8.3:compile
[INFO] |  |  |  |  \- com.sun.jersey:jersey-core:jar:1.9:compile
[INFO] |  |  |  +- com.aliyun:aliyun-java-sdk-core:jar:3.4.0:compile
[INFO] |  |  |  +- com.aliyun:aliyun-java-sdk-ram:jar:3.0.0:compile
[INFO] |  |  |  +- com.aliyun:aliyun-java-sdk-sts:jar:3.0.0:compile
[INFO] |  |  |  \- com.aliyun:aliyun-java-sdk-ecs:jar:4.2.0:compile
[INFO] |  |  \- cc.mumshop.cloud:mumshop-cloud-common:jar:2.3-SNAPSHOT:compile
[INFO] |  |     +- us.codecraft:webmagic-core:jar:0.7.3:compile
[INFO] |  |     |  +- commons-io:commons-io:jar:1.3.2:compile
[INFO] |  |     |  \- com.jayway.jsonpath:json-path:jar:2.4.0:compile
[INFO] |  |     |     \- net.minidev:json-smart:jar:2.3:compile
[INFO] |  |     |        \- net.minidev:accessors-smart:jar:1.2:compile
[INFO] |  |     |           \- org.ow2.asm:asm:jar:6.1.1:compile
[INFO] |  |     +- us.codecraft:webmagic-extension:jar:0.7.3:compile
[INFO] |  |     +- com.alibaba.platform.shared:ocean.client:jar:1.0.0:compile
[INFO] |  |     \- com.huaban:jieba-analysis:jar:1.0.2:compile
[INFO] |  \- com.fasterxml.jackson.core:jackson-databind:jar:2.9.8:compile
[INFO] |     +- com.fasterxml.jackson.core:jackson-annotations:jar:2.9.0:compile
[INFO] |     \- com.fasterxml.jackson.core:jackson-core:jar:2.9.8:compile
[INFO] +- com.hankcs:hanlp:jar:portable-1.7.3:compile
[INFO] +- xyz.downgoon:snowflake:jar:1.0.0:compile
[INFO] +- org.nutz:nutz-plugins-websocket:jar:1.r.68-SNAPSHOT:compile
[INFO] +- com.sun.xml.ws:jaxws-rt:jar:2.1.4:compile
[INFO] |  +- javax.xml.ws:jaxws-api:jar:2.1:compile
[INFO] |  |  \- javax.xml.bind:jaxb-api:jar:2.3.1:compile
[INFO] |  |     \- javax.activation:javax.activation-api:jar:1.2.0:compile
[INFO] |  +- com.sun.xml.bind:jaxb-impl:jar:2.1.7:compile
[INFO] |  +- com.sun.xml.messaging.saaj:saaj-impl:jar:1.3.1:compile
[INFO] |  |  \- javax.xml.soap:saaj-api:jar:1.3:compile
[INFO] |  +- com.sun.xml.stream.buffer:streambuffer:jar:0.7:compile
[INFO] |  +- com.sun.xml.stream:sjsxp:jar:1.0.1:compile
[INFO] |  |  \- javax.xml.stream:stax-api:jar:1.0:compile
[INFO] |  +- org.jvnet.staxex:stax-ex:jar:1.2:compile
[INFO] |  +- com.sun.org.apache.xml.internal:resolver:jar:20050927:compile
[INFO] |  \- org.jvnet:mimepull:jar:1.2:compile
[INFO] +- net.sf.barcode4j:barcode4j-light:jar:2.0:compile
[INFO] |  \- xml-apis:xml-apis:jar:1.3.04:compile
[INFO] +- org.nutz:nutzboot-starter-dubbo:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- org.nutz:nutz-integration-dubbo:jar:1.r.68-SNAPSHOT:compile
[INFO] |  |  \- org.apache.curator:curator-framework:jar:4.0.1:compile
[INFO] |  |     \- org.apache.curator:curator-client:jar:4.0.1:compile
[INFO] |  +- com.alibaba:dubbo:jar:2.6.6:compile
[INFO] |  |  +- org.springframework:spring-context:jar:4.3.21.RELEASE:compile
[INFO] |  |  |  +- org.springframework:spring-aop:jar:4.3.21.RELEASE:compile
[INFO] |  |  |  +- org.springframework:spring-beans:jar:4.3.21.RELEASE:compile
[INFO] |  |  |  +- org.springframework:spring-core:jar:4.3.21.RELEASE:compile
[INFO] |  |  |  \- org.springframework:spring-expression:jar:4.3.21.RELEASE:compile
[INFO] |  |  +- org.javassist:javassist:jar:3.24.0-GA:compile
[INFO] |  |  \- org.jboss.netty:netty:jar:3.2.5.Final:compile
[INFO] |  +- org.slf4j:jcl-over-slf4j:jar:1.7.25:compile
[INFO] |  \- org.nutz:nutzboot-core:jar:2.3.6-SNAPSHOT:compile
[INFO] |     \- javax.servlet:javax.servlet-api:jar:3.1.0:compile
[INFO] +- org.nutz:nutzboot-starter-zkclient:jar:2.3.6-SNAPSHOT:compile
[INFO] |  \- com.101tec:zkclient:jar:0.10:compile
[INFO] |     \- org.apache.zookeeper:zookeeper:jar:3.4.8:compile
[INFO] |        +- jline:jline:jar:0.9.94:compile
[INFO] |        \- io.netty:netty:jar:3.7.0.Final:compile
[INFO] +- org.nutz:nutzboot-starter-mongodb:jar:2.3.6-SNAPSHOT:compile
[INFO] |  \- org.nutz:nutz-plugins-mongodb:jar:1.r.68-SNAPSHOT:compile
[INFO] |     \- org.mongodb:mongo-java-driver:jar:3.5.0:compile
[INFO] +- commons-beanutils:commons-beanutils:jar:1.9.3:compile
[INFO] |  \- commons-logging:commons-logging:jar:1.2:compile
[INFO] +- org.apache.commons:commons-collections4:jar:4.1:compile
[INFO] +- org.lucee:commons-httpclient:jar:3.1.0:compile
[INFO] +- org.nutz:nutz-plugins-ip2region:jar:1.r.65:compile
[INFO] +- org.slf4j:slf4j-log4j12:jar:1.7.25:compile
[INFO] |  \- log4j:log4j:jar:1.2.17:compile
[INFO] +- javax.mail:mail:jar:1.4.7:compile
[INFO] |  \- javax.activation:activation:jar:1.1:compile
[INFO] +- club.zhcs:axe-captcha:jar:1.5:compile
[INFO] +- org.apache.ant:ant:jar:1.9.4:compile
[INFO] |  \- org.apache.ant:ant-launcher:jar:1.9.4:compile
[INFO] +- org.nutz:nutz-integration-json4excel:jar:1.r.68-SNAPSHOT:compile
[INFO] |  +- org.apache.poi:poi:jar:3.17:compile
[INFO] |  +- org.apache.poi:poi-ooxml:jar:3.17:compile
[INFO] |  |  \- com.github.virtuald:curvesapi:jar:1.04:compile
[INFO] |  +- org.apache.poi:poi-ooxml-schemas:jar:3.17:compile
[INFO] |  |  \- org.apache.xmlbeans:xmlbeans:jar:2.6.0:compile
[INFO] |  |     \- stax:stax-api:jar:1.0.1:compile
[INFO] |  \- org.apache.poi:ooxml-schemas:jar:1.3:compile
[INFO] +- org.nutz:nutz-plugins-slog:jar:1.r.68-SNAPSHOT:compile
[INFO] +- org.nutz:nutz-plugins-event:jar:1.r.68-SNAPSHOT:compile
[INFO] +- org.nutz:nutzboot-starter-feign:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- io.github.openfeign:feign-core:jar:9.5.1:compile
[INFO] |  +- io.github.openfeign:feign-slf4j:jar:9.5.1:compile
[INFO] |  +- io.github.openfeign:feign-hystrix:jar:9.5.1:compile
[INFO] |  |  +- com.netflix.archaius:archaius-core:jar:0.6.6:compile
[INFO] |  |  \- com.netflix.hystrix:hystrix-core:jar:1.5.12:compile
[INFO] |  |     \- org.hdrhistogram:HdrHistogram:jar:2.1.9:compile
[INFO] |  +- io.github.openfeign:feign-ribbon:jar:9.5.1:compile
[INFO] |  +- com.netflix.ribbon:ribbon-loadbalancer:jar:2.2.4:compile
[INFO] |  |  +- com.netflix.netflix-commons:netflix-statistics:jar:0.1.1:runtime
[INFO] |  |  +- io.reactivex:rxjava:jar:1.1.10:compile
[INFO] |  |  +- com.netflix.servo:servo-core:jar:0.10.1:runtime
[INFO] |  |  |  \- com.netflix.servo:servo-internal:jar:0.10.1:runtime
[INFO] |  |  +- com.google.guava:guava:jar:16.0.1:compile
[INFO] |  |  \- com.netflix.netflix-commons:netflix-commons-util:jar:0.1.1:runtime
[INFO] |  \- com.netflix.ribbon:ribbon-core:jar:2.2.4:compile
[INFO] |     +- com.google.code.findbugs:annotations:jar:2.0.0:runtime
[INFO] |     \- commons-configuration:commons-configuration:jar:1.8:runtime
[INFO] +- org.nutz:nutzboot-starter-freemarker:jar:2.3.6-SNAPSHOT:compile
[INFO] |  \- org.freemarker:freemarker:jar:2.3.28:compile
[INFO] +- org.nutz:nutzboot-starter-swagger:jar:2.3.6-SNAPSHOT:compile
[INFO] |  \- io.swagger:swagger-servlet:jar:1.5.18:compile
[INFO] |     +- io.swagger:swagger-core:jar:1.5.18:compile
[INFO] |     |  +- org.apache.commons:commons-lang3:jar:3.2.1:compile
[INFO] |     |  +- com.fasterxml.jackson.dataformat:jackson-dataformat-yaml:jar:2.9.3:compile
[INFO] |     |  |  \- org.yaml:snakeyaml:jar:1.18:compile
[INFO] |     |  +- io.swagger:swagger-models:jar:1.5.18:compile
[INFO] |     |  |  \- io.swagger:swagger-annotations:jar:1.5.18:compile
[INFO] |     |  \- javax.validation:validation-api:jar:1.1.0.Final:compile
[INFO] |     \- org.reflections:reflections:jar:0.9.11:compile
[INFO] +- org.apache.httpcomponents:httpclient:jar:4.4.1:compile
[INFO] |  +- org.apache.httpcomponents:httpcore:jar:4.4.1:compile
[INFO] |  \- commons-codec:commons-codec:jar:1.9:compile
[INFO] +- org.brickred:socialauth:jar:4.14:compile
[INFO] |  \- org.openid4java:openid4java-consumer:jar:0.9.5:compile
[INFO] |     +- org.openid4java:openid4java-nodeps:jar:0.9.5:compile
[INFO] |     \- net.sourceforge.nekohtml:nekohtml:jar:1.9.7:compile
[INFO] |        \- xerces:xercesImpl:jar:2.8.1:compile
[INFO] +- us.codecraft:xsoup:jar:0.3.1:compile
[INFO] |  +- org.jsoup:jsoup:jar:1.8.3:compile
[INFO] |  \- org.assertj:assertj-core:jar:1.5.0:compile
[INFO] +- org.nutz:nutz-plugins-daocache:jar:1.r.68-SNAPSHOT:compile
[INFO] +- org.nutz:nutz:jar:1.r.68-SNAPSHOT:compile
[INFO] +- org.nutz:nutzboot-starter-ngrok:jar:2.3.6-SNAPSHOT:compile
[INFO] |  \- org.nutz:nutz-plugins-ngrok:jar:1.r.68-SNAPSHOT:compile
[INFO] +- org.nutz:nutzboot-starter-undertow:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- io.undertow:undertow-core:jar:1.4.26.Final:compile
[INFO] |  |  +- org.jboss.logging:jboss-logging:jar:3.3.2.Final:compile
[INFO] |  |  +- org.jboss.xnio:xnio-api:jar:3.3.8.Final:compile
[INFO] |  |  \- org.jboss.xnio:xnio-nio:jar:3.3.8.Final:runtime
[INFO] |  +- io.undertow:undertow-servlet:jar:1.4.26.Final:compile
[INFO] |  |  \- org.jboss.spec.javax.servlet:jboss-servlet-api_3.1_spec:jar:1.0.2.Final:compile
[INFO] |  +- io.undertow:undertow-websockets-jsr:jar:1.4.26.Final:compile
[INFO] |  |  \- org.jboss.spec.javax.websocket:jboss-websocket-api_1.1_spec:jar:1.1.3.Final:compile
[INFO] |  \- org.nutz:nutzboot-servlet3:jar:2.3.6-SNAPSHOT:compile
[INFO] |     \- javax.annotation:javax.annotation-api:jar:1.2:compile
[INFO] +- org.nutz:nutzboot-starter-nutz-mvc:jar:2.3.6-SNAPSHOT:compile
[INFO] +- org.nutz:nutzboot-starter-jdbc:jar:2.3.6-SNAPSHOT:compile
[INFO] +- org.nutz:nutzboot-starter-shiro:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- org.nutz:nutz-integration-shiro:jar:1.r.68-SNAPSHOT:compile
[INFO] |  +- org.apache.shiro:shiro-web:jar:1.3.2:compile
[INFO] |  |  \- org.apache.shiro:shiro-core:jar:1.3.2:compile
[INFO] |  +- org.apache.shiro:shiro-ehcache:jar:1.3.2:compile
[INFO] |  +- net.sf.ehcache:ehcache:jar:2.10.4:compile
[INFO] |  \- org.nutz:nutz-plugins-cache:jar:1.r.68-SNAPSHOT:compile
[INFO] +- org.nutz:nutzboot-starter-redis:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- org.nutz:nutz-integration-jedis:jar:1.r.68-SNAPSHOT:compile
[INFO] |  \- redis.clients:jedis:jar:2.9.0:compile
[INFO] |     \- org.apache.commons:commons-pool2:jar:2.4.2:compile
[INFO] +- org.nutz:nutzboot-starter-quartz:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- org.nutz:nutz-integration-quartz:jar:1.r.68-SNAPSHOT:compile
[INFO] |  \- org.quartz-scheduler:quartz:jar:2.3.0:compile
[INFO] |     \- com.mchange:mchange-commons-java:jar:0.2.11:compile
[INFO] +- org.nutz:nutzboot-starter-nutz-dao:jar:2.3.6-SNAPSHOT:compile
[INFO] +- mysql:mysql-connector-java:jar:5.1.44:compile
[INFO] +- com.alibaba:druid:jar:1.1.16:compile
[INFO] +- org.nutz:nutzboot-starter-sentinel-dubbo:jar:2.3.6-SNAPSHOT:compile
[INFO] |  +- com.alibaba.csp:sentinel-dubbo-adapter:jar:1.5.0:compile
[INFO] |  |  \- com.alibaba.csp:sentinel-core:jar:1.5.0:compile
[INFO] |  +- com.alibaba.csp:sentinel-transport-simple-http:jar:1.5.0:compile
[INFO] |  |  \- com.alibaba.csp:sentinel-transport-common:jar:1.5.0:compile
[INFO] |  |     \- com.alibaba.csp:sentinel-datasource-extension:jar:1.5.0:compile
[INFO] |  +- com.alibaba.csp:sentinel-cluster-client-default:jar:1.5.0:compile
[INFO] |  |  +- com.alibaba.csp:sentinel-cluster-common-default:jar:1.5.0:compile
[INFO] |  |  \- io.netty:netty-handler:jar:4.1.31.Final:compile
[INFO] |  |     +- io.netty:netty-buffer:jar:4.1.31.Final:compile
[INFO] |  |     |  \- io.netty:netty-common:jar:4.1.31.Final:compile
[INFO] |  |     +- io.netty:netty-transport:jar:4.1.31.Final:compile
[INFO] |  |     |  \- io.netty:netty-resolver:jar:4.1.31.Final:compile
[INFO] |  |     \- io.netty:netty-codec:jar:4.1.31.Final:compile
[INFO] |  +- com.alibaba.csp:sentinel-cluster-server-default:jar:1.5.0:compile
[INFO] |  \- com.alibaba.csp:sentinel-parameter-flow-control:jar:1.5.0:compile
[INFO] |     \- com.googlecode.concurrentlinkedhashmap:concurrentlinkedhashmap-lru:jar:1.4.2:compile
[INFO] \- org.nutz:nutzboot-starter-sentinel-annotation:jar:2.3.6-SNAPSHOT:compile
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 8.135 s
[INFO] Finished at: 2019-05-28T09:26:11+08:00
[INFO] ------------------------------------------------------------------------

咦,难道是undertow版本问题

我貌似知道了

添加回复
请先登陆
回到顶部