NutzCN Logo
问答 dependencyManagement配置的com.budwk.starter三方模块引用不到
发布于 116天前 作者 Ethan 400 次浏览 复制 上一个帖子 下一个帖子
标签: nutzwk

直接从GitHub拉下来的源码,wk-ucenter项目下的pom文件中,以下配置hutool-crypto打包package的时候报错:
'dependencies.dependency.version' for cn.hutool:hutool-crypto:jar is missing. @ line 99, column 21
直接在idea里启动项目正常,但是想打jar包发布到服务器,打包时报错。请问大家怎么解决?谢谢

    <dependency>
        <groupId>cn.hutool</groupId>
        <artifactId>hutool-crypto</artifactId>
    </dependency>

<dependencyManagement>
    <dependencies>
        <dependency>
            <groupId>com.budwk.starter</groupId>
            <artifactId>wk-starter-dependencies</artifactId>
            <version>${wk.version}</version>
            <type>pom</type>
            <scope>import</scope>
        </dependency>
    </dependencies>
</dependencyManagement>
3 回复

补充一下,budwk V7版本,目前的最新版本

如下,增加hutool-crypto的版本信息后就可以package打包了。但是请问为什么上边从com.budwk.starter引用不到?

    <hutool.version>5.7.19</hutool.version>

    <dependency>
        <groupId>cn.hutool</groupId>
        <artifactId>hutool-crypto</artifactId>
        <version>${hutool.version}</version>
    </dependency>
添加回复
请先登陆
回到顶部