NutzCN Logo
问答 今天突然之间编译出现错误
发布于 24天前 作者 shufu 142 次浏览 复制 上一个帖子 下一个帖子
标签:

昨天编译还没有问题,今天早上开始idea编译就发生如下问题:

12:36:04.629 [com.podiy.app.insure.MainLauncher.main()] DEBUG org.nutz.boot.NbApp - using org.nutz.boot.config.impl.YamlConfigureLoader as ConfigureLoader
12:36:04.629 [com.podiy.app.insure.MainLauncher.main()] ERROR org.nutz.boot.NbApp - something happen!!
java.lang.UnsupportedClassVersionError: org/nutz/boot/config/impl/YamlConfigureLoader has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at org.nutz.boot.NbApp.prepareConfigureLoader(NbApp.java:360)
	at org.nutz.boot.NbApp.prepare(NbApp.java:268)
	at org.nutz.boot.NbApp.execute(NbApp.java:201)
	at org.nutz.boot.NbApp.run(NbApp.java:182)
	at com.podiy.app.insure.MainLauncher.main(MainLauncher.java:76)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.codehaus.mojo.exec.ExecJavaMojo$1.run(ExecJavaMojo.java:282)
	at java.lang.Thread.run(Thread.java:748)
12:36:04.770 [com.podiy.app.insure.MainLauncher.main()] DEBUG org.nutz.castor.Castors - Using 107 castor for Castors

用的是如下版本:

<nutz.version>1.r.68-SNAPSHOT</nutz.version>
		<nutzplug.version>1.r.68-SNAPSHOT</nutzplug.version>
		<nutzboot.version>2.4.3-SNAPSHOT</nutzboot.version>
3 回复

应该是昨天发布这个版本出现问题:
nutzboot-core-2.4.3-20220719.024019-37

主要是2.4.3-SNAPSHOT自动下载了如上版本

首先建议项目中使用release版本,
其次,这个错,是因为我 mvn clean deploy 时,少敲了 clean 。。。

添加回复
请先登陆
回到顶部